Utilitaire de résolution des problèmes de licence logicielle FPGA Intel®

FAQ

Forum aux questions

Utilisez la fonction « Mise à jour de licence Web » pour télécharger et installer automatiquement votre fichier de licence le plus à jour. Cliquez sur Mise à jour de la licence Web dans la boîte de dialogue Configuration de la licence (menu Outils).

Si vous avez encore besoin d’aide, consultez la section configuration du fichier de licence « Comment vérifier la configuration du fichier de licence » sur cette page pour votre logiciel.

Vous devez obtenir un fichier de licence auprès d’Intel et le configurer pour utiliser le logiciel de développement Intel® Quartus®.
Si vous utilisez la version 3.0 du logiciel de développement Intel Quartus et que vous n’avez pas configuré de fichier de licence, vous pouvez demander un fichier de licence lorsque vous démarrez le logiciel.
Vous pouvez également demander un fichier de licence à partir du Centre de licences Intel FPGA.
Le fichier de licence est envoyé sous forme de pièce jointe à un e-mail. Enregistrez le fichier de licence sur votre disque dur. Intel recommande d’enregistrer le fichier de licence dans le même répertoire que le logiciel que vous utilisez.

Si vous rencontrez toujours un problème, vérifiez que le logiciel de développement Intel® Quartus® est configuré pour pointer vers un fichier de licence valide afin de s’exécuter. Pour plus de détails sur la façon de vérifier la configuration du fichier de licence, veuillez vous référer à la section « Comment vérifier la configuration de la licence » sur cette page.

FAQ

Forum aux questions

Votre logiciel est-il concédé sous licence avec un ID de carte réseau ou un ID de disque dur ?

ID de la carte réseau: Ouvrez la fenêtre Configuration de la licence dans le logiciel de développement Intel® Quartus® (menu Outils -> Configuration de la licence). Vérifiez si la section ID de carte d’interface réseau (NIC) de la zone Informations système correspond à l’ID de carte réseau spécifié dans votre fichier de licence.

ID du disque dur: Voici d’autres ressources que vous pouvez utiliser pour vous aider à résoudre le problème que vous pouvez rencontrer avec les produits FPGA Intel®.

Recherchez des solutions dans la base de connaissances.

Parcourir la documentation.

Installation et licence du logiciel Intel FPGA (PDF)

Manuel du générateur DSP (PDF)

Envoyez une demande de service à mySupport,le système de support technique en ligne d’Intel.

Pour savoir si votre logiciel est sous licence avec un ID de carte d’interface réseau (NIC) ou un ID de disque dur, ouvrez votre fichier de licence dans un éditeur de texte.

S’il inclut le mot HOSTID suivi d’un nombre hexadécimal à 12 chiffres, le logiciel est concédé sous licence avec un ID de carte réseau.
Exemple : HOSTID=00C04FA0B182 est sous licence avec un ID de carte réseau.

Des problèmes de licence avec T-Guards peuvent se produire si le T-Guard n’est pas reconnu par le logiciel. Cela peut se produire si le port parallèle de votre ordinateur n’est pas configuré pour le mode ECP.
Vérifiez dans le BIOS que le port parallèle est défini sur le mode ECP.

Votre logiciel est-il concédé sous licence avec un ID de carte réseau ou un ID de disque dur ?

Vérifiez les paramètres du BIOS: Le pilote Sentinel doit être activé pour le port parallèle sur lequel vous avez branché le T-Guard. Exécutez le programme setupx86.exe dans le répertoire \drivers.
Choisissez Configurer le pilote Sentinel dans le menu Fichier.
Assurez-vous que l’utilisation? La colonne est définie sur Oui pour votre port parallèle.
Quittez le programme Sentinel Driver et redémarrez votre ordinateur.

Différentes versions du BIOS ont des procédures différentes pour effectuer ce paramètre. Consultez le fournisseur de votre ordinateur pour obtenir de l’aide.

Ouvrez la fenêtre Configuration de la licence dans le logiciel de développement Intel® Quartus® (menu Outils -> Configuration de la licence).
Vérifiez si la section ID de carte d’interface réseau (NIC) de la zone Informations système correspond à l’ID de carte réseau spécifié dans votre fichier de licence. Vérifiez que votre ID de carte réseau s’affiche correctement.

Si vous avez besoin d’aide supplémentaire, vous pourrez peut-être résoudre ce problème en ajoutant une clé dans le Registre Windows. Utilisez l’Éditeur du Registre (regedt32.exe) pour afficher la clé suivante dans le Registre : HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

Ajoutez la valeur de Registre suivante :

Nom de la valeur DésactiverDHCPMediaSense
Type de données REG_DWORD -Booléen
Valeur 1

Redémarrez votre ordinateur pour que la modification prenne effet.

Définir la clé de Registre DisableDHCPMediaSense

Des problèmes avec les licences flottantes peuvent survenir en raison de problèmes de configuration sur le serveur de licences.
Exécutez la commande lmutil lmstat -a -c port@host où port@host est le numéro de port et le nom d’hôte du serveur de licences (1800@server1, par exemple).
Examinez la sortie de la commande. Le gestionnaire de licences et le démon Intel FPGA doivent signaler UP.
La version 3.0 du logiciel de développement Intel Quartus® nécessite que les versions du gestionnaire de licences et du démon FpgA Intel soient supérieures à 8.0.

Si l’état du serveur de licences est OK, il est possible qu’il y ait un problème de configuration sur l’ordinateur client.
Vérifiez que la variable d’environnement LM_LICENSE_FILE est correctement définie sur l’ordinateur client.

Vérifiez la variable d’environnement LM_LICENSE_FILE.

Sous UNIX*, tapez env |grep LM_LICENSE_FILE et assurez-vous que la valeur correspond à l’emplacement du fichier de licence.
Sous Windows*, tapez set | recherchez « LM_LICENSE_FILE » et assurez-vous que la valeur correspond à l’emplacement du fichier de licence.
Pour plus d’informations sur la définition de la variable d’environnement LM_LICENSE_FILE, consultez la note AN 340: Intel FPGA Software Licensing Application Note.

Si le gestionnaire de licences et les versions atlérées sont inférieurs à 8.0, Intel recommande d’utiliser les dernières versions du gestionnaire de licences (lmgrd) et du démon fournisseur (Intel FPGA), qui sont inclus avec le logiciel de développement Intel® Quartus®.

Des versions mises à jour des fichiers sont également disponibles en téléchargement sur la page Téléchargements du démon de licence.
Redémarrez le gestionnaire de licences après la mise à jour des fichiers.

FAQ

Forum aux questions

Selon le moment où votre fichier de licence expire, vous aurez peut-être besoin d’un nouveau fichier de licence pour utiliser la nouvelle version du logiciel. Votre fichier de licence a peut-être expiré.

Pour obtenir un nouveau fichier de licence pour Quarterus development softawre version 4.0 ou ultérieure, utilisez la fonction « Mise à jour de licence Web » pour télécharger et installer automatiquement votre fichier de licence le plus à jour.

Cliquez sur Mise à jour de la licence Web dans la boîte de dialogue Configuration de la licence (menu Outils). Reportez-vous également à la section « Comment obtenir un nouveau fichier de licence » et sélectionnez « Logiciel de développement Intel Quartus version 4.0 ou ultérieure ».

Pour obtenir un fichier de licence pour la version 3.0 ou antérieure, vous devrez obtenir un fichier de licence d’Intel et le configurer pour utiliser le logiciel de développement Intel® Quartus®.

Si vous utilisez la version 3.0 du logiciel de développement Intel Quartus et que vous n’avez pas configuré de fichier de licence, vous pouvez demander un fichier de licence lorsque vous démarrez le logiciel.
Vous pouvez également demander un fichier de licence à partir du Centre de licences Intel FPGA.
Le fichier de licence est envoyé sous forme de pièce jointe à un e-mail. Enregistrez le fichier de licence sur votre disque dur. Intel recommande d’enregistrer le fichier de licence dans le même répertoire que le logiciel que vous utilisez. Vous pouvez également vous référer à la section « Comment obtenir un nouveau fichier de licence » et sélectionner « Logiciel de développement Intel Quartus version 3.0 ou antérieure ».

Si vous avez déjà installé un nouveau fichier de licence, vérifiez que le logiciel de développement Intel® Quartus® est configuré pour pointer vers un fichier de licence valide afin de s’exécuter.

Pour vérifier la configuration du fichier de licence, reportez-vous à la section « Comment vérifier la configuration du fichier de licence » et sélectionnez l’un des logiciels répertoriés ci-dessous.

  • Intel® Quartus® Édition Lite
  • Logiciel de développement Intel Quartus avec un T-Guard
  • Logiciel de développement Intel Quartus inclus avec un kit de développement
  • Logiciel de développement Intel Quartus avec un serveur de licences flottantes

Un T-Guard est une clé matérielle ou un dongle qui se branche sur le port parallèle de votre ordinateur.

Si vous avez toujours besoin d’aide, suivez les étapes ci-dessous.

Ouvrez la fenêtre Configuration de la licence (menu Outils -> Configuration de la licence). Le champ Fichier de licence doit avoir le chemin d’accès à votre fichier de licence ou un serveur de licences port@host spécifié. Si vous devez accéder à un fichier de licence, cliquez sur le bouton [. . .] et sélectionnez le fichier de licence sur votre disque dur.

Exemples de valeurs de champ de fichier de licence valides :

Chemin d’accès au fichier de licence : c:\quartus\license.dat

port@host : 1800@server1

Vous devez configurer un fichier de licence pour utiliser le logiciel de développement Intel® Quartus®. Vous pouvez demander un fichier de licence sur le site Web d’Intel si vous n’en avez pas déjà un.

Pour obtenir un nouveau fichier de licence, veuillez vous référer à la section « Comment obtenir un nouveau fichier de licence » sur cette page.

Si vous avez déjà installé un fichier de licence, vérifiez si le logiciel de développement Intel® Quartus® est configuré pour pointer vers un fichier de licence valide afin de s’exécuter. Pour savoir comment vérifier la configuration d’un fichier de licence, reportez-vous à la section « Comment vérifier la configuration du fichier de licence » sur cette page.

Votre logiciel cessera de fonctionner si votre fichier de licence expire.

Votre fichier de licence a peut-être expiré. Veuillez obtenir un nouveau fichier de licence discuté dans la section précédente « Comment obtenir un nouveau fichier de licence ».

Si le fichier de licence n’a pas expiré, vérifiez que le logiciel de développement Intel® Quartus® est configuré pour pointer vers un fichier de licence valide afin de s’exécuter. Veirfy le logiciel est pointé vers la licence. Pour savoir comment s’il vous plaît se référer à la section « Comment vérifier la configuration du fichier de licence ».

Si vous rencontrez toujours un problème, suivez les étapes ci-dessous :

Ouvrez la fenêtre Configuration de la licence (menu Outils -> Configuration de la licence). Le champ Fichier de licence doit avoir le chemin d’accès à votre fichier de licence ou un serveur de licences port@host spécifié.
Si vous devez accéder à un fichier de licence, cliquez sur le bouton [. . .] et sélectionnez le fichier de licence sur votre disque dur.

Exemples de valeurs de champ de fichier de licence valides :

Chemin d’accès au fichier de licence : c:\quartus\license.dat

port@host : 1800@server1

FAQ

Forum aux questions

Sélectionnez l’un des logiciels Quartus ci-dessous que vous utilisez pour plus de détails:

Logiciels Intel Quartus Prime Pro et Standard Edition

La licence ModelSim*-Intel FPGA est limitée dans le temps. Votre fichier de licence a peut-être expiré. Dans ce cas, vous devez renouveler votre abonnement logiciel avec Intel. Vous pouvez le faire via l’Intel eStore.

Si l’état du serveur de licences est extrait, il peut y avoir un problème de configuration sur l’ordinateur client. Vérifiez que la variable d’environnement LM_LICENSE_FILE est correctement définie sur l’ordinateur client.

Sur le type UNIX : env |grep LM_LICENSE_FILE. Assurez-vous que la valeur correspond à l’emplacement du fichier de licence.
Sous Windows, tapez : définir | trouvez « LM_LICENSE_FILE ». Assurez-vous que la valeur correspond à l’emplacement du fichier de licence.
Pour plus d’informations sur la définition de la variable d’environnement LM_LICENSE_FILE, consultez AN 340: Intel FPGA Software Licensing Application Note).

Logiciel Intel Quartus Prime Lite Edition

Le logiciel ModelSim* - Intel FPGA n’est pas inclus avec les cartes de développement Intel® Quartus® Prime Lite Edition ou avec les cartes de développement. Vous devez acheter un abonnement complet au logiciel Intel® FPGA afin d’obtenir la licence FPGA ModelSim*-Intel. Vous pouvez acheter l’abonnement complet dans l’Intel eStore.

Logiciel de développement Intel Quartus avec kit de développement

Le logiciel ModelSim* - Intel FPGA n’est pas inclus avec les cartes de développement Intel® Quartus® Prime Lite Edition ou avec les cartes de développement. Vous devez acheter un abonnement complet au logiciel Intel® FPGA afin d’obtenir la licence FPGA ModelSim*-Intel. Vous pouvez acheter l’abonnement complet dans l’Intel eStore.

Vous avez atteint la fin de cet utilitaire de résolution des problèmes :

Voici d’autres ressources que vous pouvez utiliser pour vous aider à résoudre le problème que vous pouvez rencontrer avec les produits Intel FPGA.

Recherchez des solutions dans la base de connaissances.

Parcourir la documentation.

Installation et licence du logiciel Intel FPGA (PDF)

Manuel du générateur DSP (PDF)

Envoyez une demande de service à mySupport,le système de support technique en ligne d’Intel.

Intel peut fournir une licence FPGA ModelSim*-Intel® pour Verilog ou VHDL.

Dans votre fichier de licence, vérifiez la langue à laquelle votre licence est destinée.

Si la langue que vous utilisez pour simuler dans ModelSim*-Intel FPGA ne correspond pas à votre langue sous licence, veuillez contacter le service clientèle Intel via mySupport.

Voici d’autres ressources que vous pouvez utiliser pour vous aider à résoudre le problème que vous pouvez rencontrer avec les produits Intel FPGA.

Recherchez des solutions dans la base de connaissances.

Parcourir la documentation.

Installation et licence du logiciel Intel FPGA (PDF)

Manuel du générateur DSP (PDF)

Envoyez une demande de service à mySupport,le système de support technique en ligne d’Intel.

Pour vérifier votre langue sous licence, ouvrez le fichier .dat licence qu’Intel vous a envoyé. Recherchez l’alteramtivsim INCREMENT ou l’alteramtivlog INCREMENT. Le premier indique une licence VHDL et le second indique une licence Verilog. Pour plus d’informations sur le format de fichier de licence, consultez la section Format de fichier de licence de AN 340: Intel FPGA Software Licensing (PDF).

FAQ

Forum aux questions

Selon le moment où votre fichier de licence expire, vous aurez peut-être besoin d’un nouveau fichier de licence pour utiliser la nouvelle version du logiciel.

Votre fichier de licence a peut-être expiré.

Pour obtenir un nouveau fichier de licence pour Quarterus development softawre version 4.0 ou ultérieure, utilisez la fonction « Mise à jour de licence Web » pour télécharger et installer automatiquement votre fichier de licence le plus à jour.

Cliquez sur Mise à jour de la licence Web dans la boîte de dialogue Configuration de la licence (menu Outils). Reportez-vous également à la section « Comment obtenir un nouveau fichier de licence » et sélectionnez « Logiciel de développement Intel Quartus version 4.0 ou ultérieure ».

Pour obtenir un fichier de licence pour la version 3.0 ou antérieure, vous devrez obtenir un fichier de licence d’Intel et le configurer pour utiliser le logiciel de développement Intel® Quartus®.

Si vous utilisez la version 3.0 du logiciel de développement Intel Quartus et que vous n’avez pas configuré de fichier de licence, vous pouvez demander un fichier de licence lorsque vous démarrez le logiciel.
Vous pouvez également demander un fichier de licence à partir du Centre de licences Intel FPGA.
Le fichier de licence est envoyé sous forme de pièce jointe à un e-mail. Enregistrez le fichier de licence sur votre disque dur. Intel recommande d’enregistrer le fichier de licence dans le même répertoire que le logiciel que vous utilisez. Vous pouvez également vous référer à la section « Comment obtenir un nouveau fichier de licence » et sélectionner « Logiciel de développement Intel Quartus version 3.0 ou antérieure ».

Si vous avez déjà installé un nouveau fichier de licence, vérifiez que le logiciel de développement Intel® Quartus® est configuré pour pointer vers un fichier de licence valide afin de s’exécuter.

Pour vérifier la configuration du fichier de licence, reportez-vous à la section « Comment vérifier la configuration du fichier de licence » et sélectionnez l’un des logiciels répertoriés ci-dessous.

    Intel® Quartus® Édition Lite

    Logiciel de développement Intel Quartus avec un T-Guard

    Logiciel de développement Intel Quartus inclus avec un kit de développement

    Logiciel de développement Intel Quartus avec un serveur de licences flottantes

Un T-Guard est une clé matérielle ou un dongle qui se branche sur le port parallèle de votre ordinateur.

Si vous avez toujours besoin d’aide, suivez les étapes ci-dessous.

Ouvrez la fenêtre Configuration de la licence (menu Outils -> Configuration de la licence). Le champ Fichier de licence doit avoir le chemin d’accès à votre fichier de licence ou un serveur de licences port@host spécifié. Si vous devez accéder à un fichier de licence, cliquez sur le bouton [. . .] et sélectionnez le fichier de licence sur votre disque dur.

Exemples de valeurs de champ de fichier de licence valides :

Chemin d’accès au fichier de licence : c:\quartus\license.dat

port@host : 1800@server1

Vous devez configurer un fichier de licence pour utiliser le logiciel de développement Intel® Quartus®. Vous pouvez demander un fichier de licence sur le site Web d’Intel si vous n’en avez pas déjà un.

Pour obtenir un nouveau fichier de licence, veuillez vous référer à la section précédente.

Si vous avez déjà installé un fichier de licence, vérifiez si le logiciel de développement Intel® Quartus® est configuré pour pointer vers un fichier de licence valide afin de s’exécuter.

Pour vérifier la configuration du fichier de licence, sélectionnez le logiciel ci-dessous et découvrez les détails.

Intel® Quartus® Édition Lite

Logiciel de développement Intel Quartus avec un T-Guard

Logiciel de développement Intel Quartus inclus avec un kit de développement

Logiciel de développement Intel Quartus avec un serveur de licences flottantes

Un T-Guard est une clé matérielle ou un dongle qui se branche sur le port parallèle de votre ordinateur.

Si vous avez toujours besoin d’aide, suivez les étapes ci-dessous.

Ouvrez la fenêtre Configuration de la licence (menu Outils -> Configuration de la licence). Le champ Fichier de licence doit avoir le chemin d’accès à votre fichier de licence ou un serveur de licences port@host spécifié.

Si vous devez accéder à un fichier de licence, cliquez sur le bouton [. . .] et sélectionnez le fichier de licence sur votre disque dur.

Exemples de valeurs de champ de fichier de licence valides :

Chemin d’accès au fichier de licence : c:\quartus\license.dat

port@host : 1800@server1

Votre logiciel cessera de fonctionner si votre fichier de licence expire et que votre fichier de licence a peut-être expiré.

Veuillez obtenir un nouveau fichier de licence discuté dans la section « Comment obtenir un nouveau fichier de licence ».

Si le fichier de licence n’a pas expiré, vérifiez que le logiciel de développement Intel® Quartus® est configuré pour pointer vers un fichier de licence valide afin de s’exécuter. Veirfy le logiciel est pointé vers la licence ou se référer à la section « Comment vérifier la configuration du fichier de licence » sur cette page.

Si vous rencontrez toujours un problème, suivez les étapes ci-dessous :

Ouvrez la fenêtre Configuration de la licence (menu Outils -> Configuration de la licence). Le champ Fichier de licence doit avoir le chemin d’accès à votre fichier de licence ou un serveur de licences port@host spécifié. Si vous devez accéder à un fichier de licence, cliquez sur le bouton [. . .] et sélectionnez le fichier de licence sur votre disque dur.

Exemples de valeurs de champ de fichier de licence valides :

Chemin d’accès au fichier de licence : c:\quartus\license.dat

port@host : 1800@server1

FAQ

Forum aux questions

Selon le moment où votre fichier de licence expire, vous aurez peut-être besoin d’un nouveau fichier de licence pour utiliser la nouvelle version du logiciel.

Veuillez vous référer à la section « Comment obtenir un nouveau fichier de licence » sur cette page.

Dans le cadre du processus de configuration de la licence, vous devez spécifier l’emplacement du fichier de licence à l’aide de la variable système LM_LICENSE_FILE.

Vérifiez que votre fichier de licence active la prise en charge de DSP Builder pour FPGA Intel. Vous pouvez trouver le logiciel activé par votre licence en vérifiant dans le fichier de licence - les lignes commençant par FEATURE ou INCREMENT répertorient les logiciels activés par la licence. Pour DSP Builder pour FPGA Intel, la ligne FEATURE requise commence par C4D5_512A. La figure suivante montre un exemple de fichier de licence.dat qui inclut la ligne FEATURE DSP Builder pour Intel FPGA (mise en surbrillance).

Votre fichier de licence doit contenir la ligne FEATURE pour activer la prise en charge de DSP Builder.

Si vous avez encore besoin d’aide, suivez les étapes ci-dessous :

Ouvrez la fenêtre Configuration de la licence (menu Outils -> Configuration de la licence). Le champ Fichier de licence doit avoir le chemin d’accès à votre fichier de licence ou un serveur de licences port@host spécifié. Si vous devez accéder à un fichier de licence, cliquez sur le bouton [. . .] et sélectionnez le fichier de licence sur votre disque dur.

Exemples de valeurs de champ de fichier de licence valides :

Chemin d’accès au fichier de licence : c:\quartus\license.dat

port@host : 1800@server1

Vérifiez la configuration du fichier de licence. Veuillez vous référer à la section « Comment vérifier la configuration du fichier de licence » pour plus de détails.

Vous devez configurer un fichier de licence pour utiliser DSP Builder pour les FPGA Intel. Vous pouvez demander un fichier de licence sur le site Web d’Intel si vous n’en avez pas déjà un.

Dans le cadre du processus de configuration de la licence, vous devez spécifier l’emplacement du fichier de licence à l’aide de la variable système LM_LICENSE_FILE.

Vérifiez que votre fichier de licence active la prise en charge de DSP Builder pour FPGA Intel. Vous pouvez trouver le logiciel activé par votre licence en vérifiant dans le fichier de licence - les lignes commençant par FEATURE ou INCREMENT répertorient les logiciels activés par la licence. Pour DSP Builder pour FPGA Intel, la ligne FEATURE requise commence par C4D5_512A. La figure suivante montre un exemple de fichier de licence.dat qui inclut la ligne FEATURE DSP Builder pour Intel FPGA (mise en surbrillance).

Vérifiez que votre fichier de licence contient la ligne FEATURE pour activer la prise en charge de DSP Builder. Si vous ne le voyez pas, veuillez contacter le service clientèle Intel pour obtenir la ligne de fonctionnalités appropriée pour DSP Builder pour les FPGA Intel et réémettre une licence.

Si vous avez besoin d’obtenir un nouveau fichier de licence, vous devez demander un fichier de licence à Intel et le configurer afin d’utiliser le DSP Builder pour intel® FPGA. Si vous avez acheté un kit de développement DSP, qui inclut DSP Builder pour FPGA Intel, sélectionnez le lien de licence approprié en fonction du kit de développement sur la page Web Intel FPGA Software Licensing. Si vous souhaitez demander une licence d’évaluation pour DSP Builder pour les FPGA Intel ou mettre à jour votre licence DSP Builder pour FPGA Intel (nouveau PC, transfert à un collègue, etc.), soumettez une demande de service mySupport. Vous trouverez des instructions sur la configuration de votre licence DSP Builder pour Intel FPGA dans la section Configurer les licences des notes de mise à jour de DSP Builder.

Si vous rencontrez toujours un problème, vérifiez que la variable d’environnement LM_LICENSE_FILE doit pointer vers l’emplacement du fichier de licence.dat. La configuration de la variable d’environnement dépend du système d’exploitation de votre PC.

Windows* NT : spécifiez l’emplacement du fichier de licence à l’aide de LM_LICENSE_FILE dans Windows NT.
Définissez la variable d’environnement dans le panneau de configuration système Windows.
1. Choisissez Paramètres -> Panneau de configuration dans le menu Démarrer de Windows.
2. Double-cliquez sur l’icône Système dans la fenêtre Panneau de configuration.
3. Cliquez sur l’onglet Environnement dans la boîte de dialogue Propriétés système.
4. Cliquez sur la liste des variables système pour la mettre en surbrillance.
5. Tapez LM_LICENSE_FILE dans la zone Variable.
6. Tapez \license.dat ou @ dans la zone de valeur.
7. Cliquez sur Définir, puis sur OK.
Si plusieurs applications utilisent cette variable d’environnement, modifiez la variable LM_LICENSE_FILE existante et séparez les différents chemins par un point-virgule (;), comme illustré dans l’exemple suivant :
c:\flexlm\licence.dat; 1800@myserver

Définir LM_LICENSE_FILE dans Windows NT

Windows 2000 ou Windows XP : spécifiez l’emplacement du fichier de licence à l’aide de LM_LICENSE_FILE dans la vue Panneau de configuration Windows 2000 ou Windows XP Classique.

Définissez la variable d’environnement dans le panneau de configuration système Windows.
1. Choisissez Paramètres -> Panneau de configuration dans le menu Démarrer de Windows.
2. Double-cliquez sur l’icône Système dans la fenêtre Panneau de configuration.
3. Cliquez sur l’onglet Avancé dans la boîte de dialogue Propriétés système.
4. Cliquez sur Variables d’environnement.
5. Cliquez sur la liste Variable système pour la mettre en surbrillance.
6. Si LM_LICENSE_FILE existe déjà, sélectionnez Modifier. Sinon, sélectionnez Nouveau et tapez LM_LICENSE_FILE.
7. Tapez \license.dat ou @ dans la zone de valeur.
8. Cliquez sur OK.
Si plusieurs applications utilisent cette variable d’environnement, modifiez la variable LM_LICENSE_FILE existante et séparez les différents chemins par un point-virgule (;), comme illustré dans l’exemple suivant :
c:\flexlm\licence.dat; 1800@myserver

Définir LM_LICENSE_FILE dans Windows 2000 ou Windows XP

Votre logiciel cessera de fonctionner si votre fichier de licence expire. Votre fichier de licence a peut-être expiré.

Vous devez demander un fichier de licence à Intel et le configurer afin d’utiliser le DSP Builder pour intel® FPGA. Si vous avez acheté un kit de développement DSP, qui inclut DSP Builder pour FPGA Intel, sélectionnez le lien de licence approprié en fonction du kit de développement sur la page Web Intel FPGA Software Licensing. Si vous souhaitez demander une licence d’évaluation pour DSP Builder pour les FPGA Intel ou mettre à jour votre licence DSP Builder pour FPGA Intel (nouveau PC, transfert à un collègue, etc.), soumettez une demande de service mySupport. Vous trouverez des instructions sur la configuration de votre licence DSP Builder pour Intel FPGA dans la section Configurer les licences des notes de mise à jour de DSP Builder.

Dans le cadre du processus de configuration de la licence, vous devez spécifier l’emplacement du fichier de licence à l’aide de la variable système LM_LICENSE_FILE.

Vérifiez que votre fichier de licence active la prise en charge de DSP Builder pour FPGA Intel. Vous pouvez trouver le logiciel activé par votre licence en vérifiant dans le fichier de licence - les lignes commençant par FEATURE ou INCREMENT répertorient les logiciels activés par la licence. Pour DSP Builder pour FPGA Intel, la ligne FEATURE requise commence par C4D5_512A. La figure suivante montre un exemple de fichier de licence.dat qui inclut la ligne FEATURE DSP Builder pour Intel FPGA (mise en surbrillance).

Vérifiez que votre fichier de licence contient la ligne FEATURE pour activer la prise en charge de DSP Builder.

Si vous rencontrez toujours un problème, vérifiez que la variable d’environnement LM_LICENSE_FILE doit pointer vers l’emplacement du fichier de licence.dat. La configuration de la variable d’environnement dépend du système d’exploitation de votre PC.

Windows* NT : spécifiez l’emplacement du fichier de licence à l’aide de LM_LICENSE_FILE dans Windows NT.
Définissez la variable d’environnement dans le panneau de configuration système Windows.
1. Choisissez Paramètres -> Panneau de configuration dans le menu Démarrer de Windows.
2. Double-cliquez sur l’icône Système dans la fenêtre Panneau de configuration.
3. Cliquez sur l’onglet Environnement dans la boîte de dialogue Propriétés système.
4. Cliquez sur la liste des variables système pour la mettre en surbrillance.
5. Tapez LM_LICENSE_FILE dans la zone Variable.
6. Tapez \license.dat ou @ dans la zone de valeur.
7. Cliquez sur Définir, puis sur OK.
Si plusieurs applications utilisent cette variable d’environnement, modifiez la variable LM_LICENSE_FILE existante et séparez les différents chemins par un point-virgule (;), comme illustré dans l’exemple suivant :
c:\flexlm\licence.dat; 1800@myserver

Définir LM_LICENSE_FILE dans Windows NT

Windows 2000 ou Windows XP : spécifiez l’emplacement du fichier de licence à l’aide de LM_LICENSE_FILE dans la vue Panneau de configuration Windows 2000 ou Windows XP Classique.

Définissez la variable d’environnement dans le panneau de configuration système Windows.
1. Choisissez Paramètres -> Panneau de configuration dans le menu Démarrer de Windows.
2. Double-cliquez sur l’icône Système dans la fenêtre Panneau de configuration.
3. Cliquez sur l’onglet Avancé dans la boîte de dialogue Propriétés système.
4. Cliquez sur Variables d’environnement.
5. Cliquez sur la liste Variable système pour la mettre en surbrillance.
6. Si LM_LICENSE_FILE existe déjà, sélectionnez Modifier. Sinon, sélectionnez Nouveau et tapez LM_LICENSE_FILE.
7. Tapez \license.dat ou @ dans la zone de valeur.
8. Cliquez sur OK.
Si plusieurs applications utilisent cette variable d’environnement, modifiez la variable LM_LICENSE_FILE existante et séparez les différents chemins par un point-virgule (;), comme illustré dans l’exemple suivant :
c:\flexlm\licence.dat; 1800@myserver

Définir LM_LICENSE_FILE dans Windows 2000 ou Windows XP

Le contenu de cette page est une combinaison de traduction humaine et informatique du contenu original en anglais. Ce contenu vous est fourni pour votre commodité et à titre informatif seulement et ne saurait être totalement exact ou complet. En cas de contradiction entre la version anglaise de cette page et la traduction, c'est la version anglaise qui prévaut. Afficher la version anglaise de cette page.